乌徒帮技术范WordPressWordPress使用 › wordpress3.4存在各种问题,建议先不要升级

wordpress3.4存在各种问题,建议先不要升级

分类:WordPress使用

更新:wordpress3.4反应出了很多问题,个人认为主要是内核变化带来的一些不兼容的问题造成的,和wordpress程序本身的逻辑没有关系。从网友们的反应来看,升级成功的占绝大多数。乌徒帮建议朋友们升级之前停用所有插件,恢复默认主题。先在本地升级,尝试升级后插件和主题的兼容性,适当修改后再在服务器上升级。

昨日wordpress3.4发布,然而从网上的反映和本人的情况来看,wordpress3.4存在比较多的问题,建议朋友们先不要升级,尝试本地测试,多次测试,并使用一段时间之后再在网站后台升级。

wordpress3.4全新安装的程序不会有问题,但是某些主题和插件并不兼容,插件开发者们最好尽快改善和修改相关功能。

如果是通过上传程序对原系统进行升级,会有一个升级数据库的过程。

从网上的反应来看,wordpress3.4升级在表现上并没有太大的变化,但是内核的变动却相对比较大,因此一些插件出现不兼容的情况。

我的网站升级之后,提示 ? ??Warning: Cannot modify header information - headers already sent by ? ?的错误,网上查找资料,有人说是文件编码问题,自己看了一下,确实文件都是ansi编码,表示非常疑惑。

综合各方面因素,wordpress3.4的情况并不乐观,因此乌徒帮建议朋友们先不要升级,看看情况再说。

已有10条评论 快速评论
  1. 否子戈 #1227楼 回复给@1225楼 2012/06/22 18:06:25 回复

    升级主要存在的问题就是主题及插件的兼容性问题

  2. 桖晞二零一二 #1225楼 2012/06/22 10:32:18 回复

    我也是第一时间升级的,没有碰到问题。就是主题的汉化全部没有了

  3. 否子戈 #1219楼 回复给@1218楼 2012/06/18 10:33:46 回复

    那应该是插件的兼容性问题吧

  4. 小曾博客 #1218楼 2012/06/17 23:37:32 回复

    我升级后 那个WP No Category Base 出了些问题 不过我在后台分类目录前缀前加了个点就好了

  5. 否子戈 #1216楼 回复给@1215楼 2012/06/16 14:35:15 回复

    3.4的兼容性受到了很大的挑战,我的主题和插件都出现了不兼容的情况,原因有多方面的,我的主题主要是文件编码的问题造成的。

  6. 阿福 #1215楼 回复给@1214楼 2012/06/16 14:16:04 回复

    貌似是使用DB-Cache之类的插件,然后出现了后台无法登陆的状况。这类的缓存插件一般在升级的时候都得关掉的吧?

  7. 否子戈 #1214楼 回复给@1213楼 2012/06/16 14:13:26 回复

    出现的什么问题呀?

  8. 阿福 #1213楼 2012/06/16 13:42:41 回复

    我也是第一时间升级。木有出现错误的情况。。。不过我的朋友出现了错误。

  9. 否子戈 #1210楼 回复给@1208楼 2012/06/16 07:47:03 回复

    3.4有一些新的变化,文件结构也有所改变,根目录下少了不少文件,新添加了一些,我的那个问题应该是和主题不兼容造成的

  10. vsBeta.COM #1208楼 2012/06/15 20:08:41 回复

    我第一时间升级的,貌似没碰到奇怪的问题

填写个人信息,赶快回复吧!